It is currently Fri Dec 15, 2017 11:44 pm

All times are UTC






Post new topic Reply to topic  [ 4 posts ] 


Author Message
 Post subject: Davis/Eleco Control Gear
PostPosted: Sun Jun 05, 2016 10:28 am 
Offline
Member
User avatar

Joined: Sat Jun 23, 2012 8:21 pm
Posts: 288
Images: 6
Hi all,

Last time I was at the council depot I picked up a Davis Thyractor ballast. Now my experience of these has been poor in the past. I must of had about 10 of these in my collection at various times and all I get is a red flash from the tube then nothing. So you can imagine my disappointment when this one did the same.....bugger. So whilst I was putting the other stuff away on the shelf I spotted one at the back of my collection. I haven't dated it so I wasn't too sure if it would work. I wired it up and hey it works. Has anyone noticed a high failure rate with these?

Regards,

Andrew


Attachments:
20160605_111729.jpg
20160605_111729.jpg [ 562.58 KiB | Viewed 1413 times ]
20160605_111723.jpg
20160605_111723.jpg [ 697.71 KiB | Viewed 1412 times ]
Top
 Profile  
 
PostPosted: Thu Jun 09, 2016 5:21 pm 
Offline
Member
User avatar

Joined: Sat Nov 21, 2009 4:54 pm
Posts: 962
Images: 24
I have one of these. I saved it from an old column in Nottinghamshire about 3-4 years ago. Although it's only used occasionally, it's always worked fine, and has been wired up to my ex Rochdale Wardle 'Solar' for at least two years .


Top
 Profile  Personal album 
 
PostPosted: Mon Sep 18, 2017 10:08 pm 
Offline
Member
User avatar

Joined: Sun Nov 09, 2014 10:20 am
Posts: 163
Images: 26
meppso wrote:
Hi all,

Last time I was at the council depot I picked up a Davis Thyractor ballast. Now my experience of these has been poor in the past. I must of had about 10 of these in my collection at various times and all I get is a red flash from the tube then nothing. So you can imagine my disappointment when this one did the same.....bugger. So whilst I was putting the other stuff away on the shelf I spotted one at the back of my collection. I haven't dated it so I wasn't too sure if it would work. I wired it up and hey it works. Has anyone noticed a high failure rate with these?

Regards,

Andrew


I have got a GEC Z9533 internally geared 35w SOX lantern, which was fitted with one of these Davis Thyractor ballast's.
It too was dead, it didn't even flash red, just did nothing, even with a different SOX tube (both the lamps I tried were working fine), I also tried it on the 55w tap, and still nothing.
These don't seem to be very reliable, I guess the internal ignitor has failed, maybe the heat of the ballast coil is what kills them?

The replacement gear will be a Parmar 35/55w SOX ballast, and an SX26 ignitor.

_________________
Thorn Beta 5 1965 - 2008 Top / Side entry


Top
 Profile  Personal album 
 
PostPosted: Thu Oct 19, 2017 11:56 am 
Offline
Member
User avatar

Joined: Sat Jun 23, 2012 8:21 pm
Posts: 288
Images: 6
Out of all the ballasts I have received these seem to have the highest failure rate!

Regards,

Andrew.


Top
 Profile  
 

Display posts from previous:  Sort by  


Post new topic Reply to topic  [ 4 posts ] 

All times are UTC



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  

Who is online

Users browsing this forum: No registered users and 1 guest



Search for:

cron